×

lumen中使用redis

96
我是你军哥
2017.04.07 10:41* 字数 65

我的lumen是5.4版本
首先在composer.json中添加

"require": {
        "php": ">=5.6.4",
        "laravel/lumen-framework": "5.4.*",
        "vlucas/phpdotenv": "~2.2",
        "illuminate/redis": "^5.4",
        "predis/predis": "1.1.*"
    },

执行composer install
然后在bootstrap/app.php
文件中把

$app->withFacades();

$app->withEloquent();

注释取消
并且注册redis类
代码如下

$app->register(Illuminate\Redis\RedisServiceProvider::class);

在要使用redis的地方

use Illuminate\Support\Facades\Redis;

就可以在lumen中愉快的使用redis了

laravel
Web note ad 1