记一次团队开发中pod install失败的问题

团队开发中,经常会有人在pod里泡一个自己需要的三方,而在我们更新代码之后蛋疼的事情有时会是这样的:

pod install 不成功,提示:

$ pod install 
Analyzing dependencies 
[!] Unable to satisfy the following requirements: 
-AliyunOSSiOS (~> 2.5.2) required by Podfile 
None of your spec sources contain a spec satisfying the dependency: AliyunOSSiOS (~> 2.5.2). 
You have either: 
* out-of-date source repos which you can update with pod repo update. 
* mistyped the name or version. 
* not added the source repo that hosts the Podspec to your Podfile. 
Note: as of CocoaPods 1.0, pod repo update does not happen on pod install by default.

反正就是你本地的repo里面的某个被别人pod过的类库已经过期或者别人pod的是一个新的版本的,你这里没有

解决方式:

rm -rf ~/.cocoapods/repos/master
pod setup
pod install --verbose --no-repo-update

结尾:pod还是很好用的,可恶的天朝无用墙徒增步骤-。-

推荐阅读更多精彩内容