Xcode 8 & Swift 3.0 迁移适配

96
azhunchen
2016.09.19 13:02* 字数 569

最近项目从 Xcode 7 + Swift 2.3 升级 Xcode 8 + Swift 3.0,遇到了一些问题,整理一下

自己的工程从2.3 升级到3.0算是顺利,只要使用 Xcode 的 Converter 即可
菜单在Edit -> Convert -> To Current Swift Syntax...

项目中难免会使用到第三方的 lib,如果第三方 lib 没有提供 Swift 3 版本,那就得另想办法。什么叫另想办法?换个 lib 呗,不然就自己造轮子
下面说一下第三方 lib 的迁移(我的项目使用 Cocoapods 管理第三方 lib,所以都以 Cocoapods 为例,其它管理工具都差不多,自行处理)

迁移大法

  1. 首先在 Podfile的最下面添加如下代码,为所有 lib 指定 Swift 版本
post_install do |installer|
    installer.pods_project.targets.each do |target|
        target.build_configurations.each do |config|
            config.build_settings['SWIFT_VERSION'] = '3.0'
        end
    end
end
  1. 将第三方 lib 切换到 Swift 3 版本。一般有在维护的 lib 都会提供 Swift 3的分支,即使没有提供,也会有热心的码农们 fork 适配。下面讲几个我项目里用的 lib 的迁移
  • Alamofire 最新版本4.0,这个版本最低适配要求是 Swift 3.0,iOS 9.0。
    由于我的项目还需要对部分 iOS 8 用户负责,所以只能遗憾和 Alamofire 告别了。昨天犹豫了半天,到底要自己造轮子,还是再找个靠谱的 lib。最终还是决定偷懒换 lib,虽然功能还不够完善,但基本够使。
    代替品是SwiftHTTP,但这个 lib 暂时没有提供 Swift 3 版本,刚才说了有热心的码农已经 fork 适配好,所以将 Podfile 中的代码 link 修改一下
    pod 'SwiftHTTP', :git => 'https://github.com/matheusfrozzi/SwiftHTTP'
  • SwiftyJSON 也是没有提供 Swift 3 版本,所以使用热心码农的
    pod 'SwiftyJSON', :git => 'https://github.com/appsailor/SwiftyJSON.git', :branch => 'swift3'
  • CocoaLumberjack
    pod 'CocoaLumberjack/Swift', :git => 'https://github.com/avielg/CocoaLumberjack'
  • 其它的不再列举啦

总结

Migrate to Swift 3.0 虽然麻烦,但是 Swift 3.0 版本的命名风格真的是很棒,写代码像在写小说一样
截取几个例子,大家细细品味,具体规范请看 Swift API Design Guidelines

遵从英语语法来编写 API 接口
Name Mutating/nonmutating method pairs
码农
Web note ad 1