gradle版本和插件版本对应关系

最近打开android studio,页面提示gradle版本又有新的升级,于是习惯性的点了下更新,结果,打包的过程中控制台就报错了,错误如下:

Error:(16, 0) Minimum supported Gradle version is 4.4 Current version is 2.3.1

查看项目,发现gradle版本目录已经修改为4.4,

原文链接:https://blog.csdn.net/dazhong2012/article/details/80585834

网上查阅资料,发现还得需要修改项目根目录下的build.gradle文件中,相应的gradle插件的版本号

dependencies {

    classpath 'com.android.tools.build:gradle:2.3.1'

    // NOTE: Do not place your application dependencies here; they belong

    // in the individual module build.gradle files

}

将原来gradle插件版本号修改为3.1.0之后,再点击同步按钮后,项目可以正常打包。

为此,专门总结一下gradle版本与相应插件版本的对应关系,下面是android官方的对应关系


---------------------

版权声明:本文为CSDN博主「dazhong2012」的原创文章,遵循CC 4.0 by-sa版权协议,转载请附上原文出处链接及本声明。

原文链接:https://blog.csdn.net/dazhong2012/article/details/80585834

推荐阅读更多精彩内容