CocoaPods相关问题总结

关于pod install 和 pod update

pod install

 第一次为项目添加依赖或者每一次修改Podfile后使用pod install。

 每次pod install被执行,都会下载和安装新的pods。被安装的pods的版本都会写入到Podfile.lock文件中。这个文件会一直跟踪已安装的每一个pods的版本号,并且锁定这些版本号。

 当你执行pod install,它只会解决那些没有在Podfile.lock文件中列出来的pods的依赖。

 对于Podfile.lock中列出的pods,只会下载Podfile.lock明确记录的版本,而不会去查看是否有新的版本。

 对于没有在Podfile.lock中列出的pods,会去匹配Podfile文件中描述的版本,如pod 'AFNetworking', '~> 3.0'。

pod update

 在执行pod update之前,可以执行pod outdated来查看有哪些pods有新的版本。

 当你执行pod update PODNAME时,CocoaPods会尝试发现PODNAME的可更新的版本,而不会去关注Podfile.lock中的版本。它会把依赖更新到最新的版本。

 当执行pod update,而不带指定的PODNAME时,CocoaPods就会将所有列在Podfile中的依赖更新到最新版本。

当pods被更新时,相应地,Podfile.lock中的pods的版本号也会更新。

Podfile.lock

  这个文件在多人合作同一个项目时可以发挥关键作用。它可以保证每个成员的pods的版本都是统一的。每一次修改Podfile.lock后,你必须要commit & push它到Repo。

当然,你可以把pod install之后生成的Pods文件夹放入到Repo中,来管理依赖版本。

一些问题的解决方法

  1.如果引入的.a文件报错link error ,那么需要执行以下代码保证团队的CocoaPods版本一致
   #删除当前版本pod,安装指定版本的pod
   sudo gem uninstall cocoapods
   sudo gem install cocoapods -v 0.37.1
   #清空pod缓存后更新由pod管理的libs
   rm -rf "${HOME}/Library/Caches/CocoaPods"
   rm -rf "`pwd`/Pods/"
   pod update

 2.在pod install时,遇到如下提示 “The dependency 'SDWebImage' is not used in any concrete target ”。这些依赖没有被任何一个target使用。

  这个问题可能出现在使用老版本的podfile文件时出现。现在新的podfile文件都会使用target NAME do来说明在哪个target中使用依赖。比如这样:

  target 'MikeAppDemo' do
        pod 'baiduMap', '~> 2.8'
 end
  只要指定好使用依赖的target,问题就可以解决了。

使用Cocoapods 导入第三方的资源时,出现如下警告:

 Your Podfile has had smart quotes sanitised. To avoid issues in the future, you should not use TextEdit for editing it.
 If you are not using TextEdit, you should turn off smart quotes in your editor of choice.
podFile.png

解决方法:不要使用文本编辑去编辑Podfile,使用Xcode编辑,或者使用终端敲命令去编辑。


podUpdate.png

遇到这种情况最好的解决方案是: podUpdate 或者重新删除cocoaPods 安装即可。'

 在终端中看到跟上面同样的红色的错误信息。

 这说明某些环境原因导致pod更新不了,可能原因有,1)gem版本太低;2)github无法链接;3).cocoapods目录下的配置信息错误。我们可以一个一个来排除,

 首先更新gem到最新版本,在终端中输入:

 $ sudo gem update --system 
 然后检查是否可以ping通github,在终端中输入:

 $ ping github.com 
 然后查看pob repo list:

 $ pod repo list
 说明Cocoapods在将它的信息下载到 ~/.cocoapods里;

  cd  到该目录里,用du -sh *命令来查看文件大小,结果显示0 repos,说明没有安装成功;

 在终端输入:

  cd ~/.cocoapods

 进入cocoapods文件后在终端输入:du -sh *
pods.png

2016-10-12日更新

  Setting up CocoaPods master repo  time out超时,不再管用!
  Setting up CocoaPods master repo1、那是因为 淘宝的那个镜像(https://ruby.taobao.org/ )已经不可用了。所以我们现在用最新支持的ruby镜像(https://gems.ruby-china.org/)

需要的命令行:

 $ gem sources -r https://rubygems.org/ 
 $ gem sources -a https://gems.ruby-china.org/ 
 $ gem sources -l 
Snip20161126_2.png
Snip20161126_3.png

解决方案:

 sudo gem install -n /usr/local/bin cocoapods --pre
Snip20161126_1.png

2:、随后出现下列错误

 [!] An error occurred while performing `Git pull` on repo `master`.
 [!] /usr/bin/git pull --ff-only
 这个错误应该是说这个节点有问题。就又找资料,然后试试把cocoapods的节点删除,重新添加一个节点,或许就行,说干就干:
 原因: Cocoapods的分支不支持当前最新的Xcode版本
 解决办法: 删除master分支 重新建立新的分支

 sudo rm -fr ~/.cocoapods/repos/master
 然后再: pod setup

忽略升级specs库

在进行pod install和pod update时候忽略升级specs库

$ pod install --verbose --no-repo-update
$ pod update --verbose --no-repo-update

cocoapods update 错误 2017-9-30日更新

loadError - cannot load such file --nanaimo
  • 根据错误知道有一个叫nanaimo的文件无法加载,于是在终端敲入命令gem list | grep nanaimo 查看该文件的列表,发现确实有两个版本的nanaimo(0.2.2和0.2.3)。
  • 卸载其中一个版本的nanaimo,在终端输入sudo uninstall nanaimo,然后选择需要卸载的版本。
  • 卸载成功后,再次pod update。成功!

推荐阅读更多精彩内容