php7安装3.4版本的phalcon扩展

php7安装phalcon扩展

适用于Centos6.x和Centos7.x系统,php使用7.1版本,wlnmp一键包已支持该扩展

phalcon扩展包地址:https://github.com/phalcon/cphalcon

1、安装所需依赖,如果在编译时还提示缺少其他依赖,请自行安装

yum install autoconf gcc gcc-c++  wget

2、下载phalcon最新稳定版

wget http://down.whsir.com/downloads/cphalcon-3.4.4.tar.gz

tar xf cphalcon-3.4.4.tar.gz

cd cphalcon-3.4.4/build/php7/64bits

/usr/local/php/bin/phpize

根据自己phpize的位置来运行即可(不知道phpize在哪的直接find / -name phpize查找),运行完提示下面信息,然后编译

Configuring for:
PHP Api Version: 20160303
Zend Module Api No: 20160303
Zend Extension Api No: 320160303

3、编译扩展模块

./configure  --with-php-config=/usr/local/php/bin/php-config
make
make install

执行完成后会显示扩展模块编译到的目录/usr/local/php/lib/php/extensions/no-debug-non-zts-20160303/

4、修改php.ini添加扩展

extension_dir  =  "/usr/local/php/lib/php/extensions/no-debug-non-zts-20160303/"

extension=phalcon.so

注意:如果之前配置过extension_dir路径了,则只需要配置extension=phalcon.so即可

保存退出,重启php

通过phpinfo可看到,扩展已生效

推荐阅读更多精彩内容