如何降低三方库的可编译版本

之前项目中遇到过一个问题,我的xcode版本为7.3.1,当我将工程的编译目标设为iOS 8.0以上时,项目运行无任何异常,但是当我调低编译目标为iOS 7.0时,这个时候再编译就会出现工程里的三方库报异常,大致意思就是说三方库的版本无法适应当前的目标iOS 7.0;


经过查阅资料,发现了解决办法,就是要降低这些三方库的最低可编译目标,让其低于项目的Deployment Target;


经过手动的改动后,再将Deployment Target调低编译,也可以完美运行.

参考:http://stackoverflow.com/questions/32516800/embedded-dylibs-frameworks-are-only-supported-on-ios-8-0-and-later-for-architect/33397764#33397764

希望对你的开发有帮助

推荐阅读更多精彩内容