Mac OS 安装java指定版本

前言

因为要用reactn ative写项目,所以需要安装android环境,java首当其冲,现在暂时只支持java8的版本,官网下载的链接一直20k,10k的下,太慢了,就用brew下载了。直接使用brew cask install java 安装的java是最新版的java11版本,官网现在还不支持,所以需要卸载重装。参考了一下
http://zoufeng.net/2018/06/29/uninstall-and-install-specific-java-version-on-mac/ 这篇文章,实现了自己的需求。

安装java指定版本

一、安装Homebrew
/** 
  * 官网 https://brew.sh/
  * Install Homebrew
  * 在终端中输入下列命令
  */

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

二、搜索版本
# 输入下列命令
 brew tap caskroom/versions
# 当成功后,检测java的版本
brew search java

search java.png
三、安装指定版本
# 有些慢,得多等会
brew cask install java8
# 结束的时候记得查看一下java的版本有没有装成功
java -version

# 卸载的时候可以使用,其他工具同理
brew cask uninstall java8

推荐阅读更多精彩内容