Android studio 更新后Dart和Flutter 不可用问题(dart incompatible with the current Android studio version)

前提

今天更新了一下Android studio 之前的版本是3.2,然后更新到3.5之后,Flutter和Dart都用不了,并且不能创建Flutter项目,然后Google 之后,发现原来是Android studio和Flutter还有Dart的版本不一致导致的。

首先

上面说了版本不一致的原因,来看看具体错误是什么,就是下面这段错误:dart incompatible with the current Android studio version,既然知道了具体原因那么下面来看解决办法。

  • 1、查看Android studio版本
    Android studio版本.png

    注意:其中的 AI-191.8026.42.35.5791312,就是我们的Android studio的build版本,我们需要下载对应的FlutterDart版本。
  • 2、跳转到jetbrains官网搜索具体Flutter插件和Dart插件
    Flutter.png

    Dart.png

注意:看上图可以看到和Android studio匹配的Flutter和Dart版本191,所以,下载对应插件然后导入到Android studio 中即可。

其次

话说Android studio 3.4之后的版本速度是挺快,但是安装插件感觉没有之前的版本方便,下面看看安装成功之后是什么样子的。

安装成功.png

这两个安装成功,重启后就可以愉快的创建Flutter项目,然后感受一下Flutter的美了。

最后

推荐一个Android交流群:493180098,欢迎来探讨问题。

致谢

Android studio 安装插件Flutter:Plugin 'Flutter' is incompatible with this installati