阿里云应用实时监控服务php应用安装探针

96
never615
2019.05.16 17:57* 字数 181

阿里云文档

其中的坑:

解压arms-php-agent.zip到工作目录后,arms-php-agent/lib目录下的libssl.so.10和libcrypto.so.10软链接到arms-php-agent/lib目录自己的文件,这两个库系统是存在的.
于是会导致报错:

openssl: /home/mallto/arms-php-agent/lib/libcrypto.so.10: version `OPENSSL_1.0.2' not found (required by openssl)

系统的openssl是1.0.2k.

解决

只需要把这两个库软链接到系统已经存在的对应库即可.
通过locate libssl.so.10找到系统中已经存在的库的地址,
然后通过软链接把arms-php-agent/lib下的这两个库的软连接地址修改为指向系统已经存在的库的地址:
ln -s /usr/lib64/libssl.so.10 /home/mallto/arms-php-agent/lib/libssl.so.10

运维
Gupao