R语言升级到3.6.0后遇到的Bioconductor安装问题

心里苦

前言

目前R 3.6.1 都已经preRelease了,我笔记本上的电脑也赶忙把R从3.5.4升级到3.6.0(当然生产力相关环境还没敢乱升级,毕竟升级一次R语言还是容易碰到很多问题的,例如这次记录)。

问题

在使用BiocManger安装一个包minfi的时候,报错:

> BiocManager::install('minfi')
Error: Bioconductor version '3.8' requires R version '3.5'; see https://bioconductor.org/install

问题探究

这看起来明显就是升级了R但是还没升级BiocManger,因为我在升级R语言的时候,library是没有变动的,导致我的包都是3.5版本的,所以第一件事就是需要更新BiocManager到3.9:

BiocManager::install(version = "3.9")

问题解决

推荐阅读更多精彩内容