Android Studio运行app时提示Please select Android SDK

96
Waullen
0.2 2017.08.11 09:32* 字数 266

有两种方式:

第一种:

转载请注明出处

http://blog.csdn.net/BruceHurrican/article/details/51755512

在做项目时协同开发时遇到的问题。

更新工程后编译提示该错误。

错误原因是,有人上传了修改的.iml文件,此处为app.iml将

改成了

导致报错。

修改方法,将jdkName改回原来即可。一般在多人协同开发时,.iml文件不要频繁上传,每个人的设置不同都有可能导致.iml文件发生变化。并且,一旦出现此错误定位非常困难。这个项目出现此问题时,我通过error信息查看我的Androidsdk 设置发现设置是正常的,但是编译就是报错。

第二种方式:

从github clone 代码到本地放到AS后发现,发现并不能点“Run”键运行app,并报错Error:Please selectAndroidSDK:

最后在File->Project Structure中将Build tools version修改,问题解决。

随笔
Web note ad 1