ubuntu下面安装ta-lib库

96
tianmh
2015.12.17 22:36* 字数 297

问题:ubuntu下面安装ta-lib库

我在Mint Linux 中安装python的插件 TA-Lib,其中python的版本是Python

2.7.6,安装TA-Lib插件直接使用pip install报错,只得从http://www.ta-

lib.org/hdr_dw.html下载ta-lib-0.4.0-src.tar.gz,然后运行如下操作:

./configure --prefix=/usr/

make

make install

安装成功。

但是随后在python里面import talib的时候,报错信息如下:

Traceback (most recent call last):

File "pystock.py", line 3, in

import talib as ta

File "build/bdist.linux-x86_64/egg/talib/__init__.py", line 4,

in

#

File "build/bdist.linux-x86_64/egg/talib/common.py", line 7, in

File "build/bdist.linux-x86_64/egg/talib/common.py", line 6, in

__bootstrap__

ImportError: /root/.python-eggs/TA_Lib-0.4.9-py2.7-linux-

x86_64.egg-tmp/talib/common.so: undefined symbol:

PyUnicodeUCS2_DecodeUTF8

在网上搜索,有几个帖子提到该问题,然后按照如下方式进行重新编译:

./configure --prefix=/usr/ --enable-unicode=ucs4

make

make install

还是没有解决该问题,仍然报相同的错误。还请大侠帮忙看看该如何解决?谢谢。

--

装miniconda,http://conda.pydata.org/miniconda.html,然后运行下面

conda install -chttps://conda.anaconda.org/quantopian ta-lib

Python学习笔记
Web note ad 1