×
广告

VMware中centos6.9上安装3.5.2、pip3

96
vonhng
2017.05.27 16:31* 字数 710

学习所用,可随意转载,转载请注明出处,或在本文下方留言说明即可,谢谢!

在windows上一直学习的都是python3.5.2,最近研究centos,但是装上cent6.9后发现,系统默认的是python2.6.6,那就尴尬了,于是就上网查资料,花了一天时间终于安装成功,本篇主要针对向我这种超小白,大神可无视。

本文在root用户下执行,“#$”后的语句是要执行语句,“#”后是注释;
#$ su     

然后输入密码即可进入。
下面进入正题:

1、为了防止出错,先安装编译python的组件gcc等

#$ yum install gcc
#$ yum groupinstall "Development tools"

2、再安装依赖包:

#$ yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel     readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel

3、下载Python3.5的源码包并编译

网上教程比较多,不做详细解释
#$ wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz #其中3.5.2可修改成自己想要的版本
#$ tar -zxvf Python-3.5.2.tgz
#$ cd Python-3.5.2
#$ ./configure --prefix=/usr/local --enable-shared  #把python3安装在此目录
#$ make
#$ make install

4、创建Python3.5软连接

1)、在/usr/bin中有python、python2、python2.6三个文件依次指向后者(即都是python2.6.6)
2)、不建议依照其他网上的方法把默认的python修改为指向3.5版本,这样的话将无法使用firewall防火墙,而且可能还有其他有影响
3)、建议另外创建一个python3的软连接
#$ ln –s /usr/local/bin/python3 /usr/bin/python3   #记住这些目录很重要

查看python版本
#$ python3 -V #v大写
如果出错,请往下看5.

5、如果运行查看版本失败

错误信息类似这样 :error while loading shared libraries: xxxxxxxx: cannot open shared object file: No such file or directory(xxxx为文件名)
解决方法:
#$ vim /etc/ld.so.conf #修改ldconfig文件
输入“i”进入编辑模式,文首新加一行 /usr/local/lib ,按“Esc”,输入“:wq”保存且返回了命令窗
#$ ldconfig

6、设置别名方便使用

#$ alias py=python3           #可用可不用

7、安装easy_install、pip的方法

#$ wget --no-check-certificate https://github.com/pypa/pip/archive/9.0.1.tar.gz   

注意:wget获取https的时候要加上: --no-check-certificate;9.0.1代表版本,可以修改成自己要的版本
#$ tar -zxvf 9.0.1.tar.gz #解压文件
#$ cd pip-9.0.1
#$ python3 setup.py install
nice!pip这就装好了。如果提示缺少某些module,网上搜一下装上去即可。

8、运用pip3安装python包

装完之后使用
#$ pip3
提示“command no found”错误。
百度一圈没找到,最后在知乎上看到一个解决此类问题的回复,尝试了一下解决问题。创建软连接
#$ ln -s /usr/local/bin/pip3 /usr/bin/pip3
#$ pip3 -V #看看能不能用,顺便看看版本
然后使用命令
#$ pip3 install xxx #xxx 为要安装的包

---本文的灵感来自cnblogs网友longxiang92和csdn网友Rock_sz的文章,并且有知乎网友(该人匿名了)的回复,感谢!。
linux
Web note ad 1