cocoapods组件化(2)

Cocoapods下多工程的配置

1. 公共资源

这里的名字必须是全小写

def common
  pod 'SnapKit', :inhibit_warnings => true
  pod 'IQKeyboardManagerSwift', :inhibit_warnings => true
  pod 'Utils', :git => 'https://gitee.com/jbxb/util-spec.git', :inhibit_warnings => true
end

2. 警告

  • inhibit_all_warnings忽略所有警告
# 说明平台是ios,版本是9.0
platform :ios, '9.0'

# 忽略引入库的所有警告(强迫症者的福音啊)
inhibit_all_warnings!
  • inhibit_warnings 忽略单个库警告
pod 'SnapKit', :inhibit_warnings => true

3. git源

pod 'Utils', :git => 'https://gitee.com/jbxb/util-spec.git'

4. 工作空间

workspace 'IOSModule.xcworkspace'

5. 工程

每个target对应一个工程文件,project用于指定target所照应的工程文件

target 'IOSModule' do
  # Comment the next line if you don't want to use dynamic frameworks
  use_frameworks!
  project 'IOSModule.xcodeproj'
  common
  # Pods for IOSModule

end

这里的IOSModule.xcodeproj代表这个工程文件相对于spec文件的路径

6. 库版本

  • 如果后面不写依赖库的具体版本号,那么cocoapods会默认选取最新版本。
pod 'SnapKit'
  • 如果你想要特定的依赖库的版本,就需要在后面写上具体版本号,格式:
pod 'SnapKit', 4.2.0
  • 指定版本范围
> 0.1 高于0.1版本(不包含0.1版本)的任意一个版本

>= 0.1 高于0.1版本(包含0.1版本)的任意一个版本

< 0.1 低于0.1版本(不包含0.1版本)的任意一个

<= 0.1低于0.1版本(包含0.1版本)的任意一个

~> 0.1.2 版本 0.1.2的版本到0.2 ,不包括0.2。这个基于你指定的版本号的最后一个部分。这个例子等效于>= 0.1.2并且 <0.2.0,并且始终是你指定范围内的最新版本。

7. 编译配置

  • pod 'PonyDebugger', :configurations => ['Debug', 'Beta']
  • pod 'PonyDebugger', :configuration => 'Debug'

8. Subspecs

# 仅安装QueryKit库下的Attribute模块
pod 'QueryKit/Attribute'

多个子模块

# 仅安装QueryKit下的Attribute和QuerySet模块
pod 'QueryKit', :subspecs => ['Attribute', 'QuerySet']

8. 使用本地文件

pod 'User', :path => './User'

9. 引用仓库根目录的podspec

  • 引入master分支(默认)
pod 'AFNetworking', :git => 'https://github.com/gowalla/AFNetworking.git'
  • 引入指定的分支
pod 'AFNetworking', :git => 'https://github.com/gowalla/AFNetworking.git', :branch => 'dev'
  • 引入某个节点的代码
pod 'AFNetworking', :git => 'https://github.com/gowalla/AFNetworking.git', :tag => '0.7.0'
  • 引入某个特殊的提交节点
pod 'AFNetworking', :git => 'https://github.com/gowalla/AFNetworking.git', :commit => '082f8319af'

10. platform

platform用于指定应建立的静态库的平台。CocoaPods提供了默认的平台版本配置:

iOS->4.3
OS X->10.6
tvOS->9.0
watchOS->2.0

如果部署目标需要iOS < 4.3,armv6体系结构将被添加到ARCHS。
例如:

#指定具体平台和版本
platform :ios, '4.0'
platform :ios

cocoapods组件化(1)
cocoapods组件化(3)

推荐阅读更多精彩内容