将自己的pod发布到CocoaPod

<article class="_2rhmJa">

1、更新cocoapods(非必要操作)

$ pod setup

如果出现 ERROR: While executing gem ... (Errno::EPERM)

Operation not permitted - /usr/bin/xcodeproj

改用该指令: sudo gem install -n /usr/local/bin cocoapods —pre

ps:查看当前版本

$ pod --version

2、注册trunk

$ pod trunk register ********@****.com(用户邮箱) '*****'(用户名) --verbose

建议邮箱名和用户名与自己的github同步,之后去自己的邮箱中找到该邮件点击验证的链接完成注册。

3、查看注册信息

$ pod trunk me

如果看到类似信息则注册成功

4、 创建样板

$ pod lib create ZQExtension

会从github上clone一个空模板。

image

填写相应设置选项。

image

完成后项目文件目录

image

5、在github上创建项目

image

将样板的仓库地址指向github上创建的远程仓库地址

$ git remote add origin https://github.com/huangzhiqiang2012/ZQExtension.git

查看当前仓库对应的远程仓库地址

$ git remote -v

如果打印出的地址是https://github.com/huangzhiqiang2012/ZQExtension.git则关联成功

6、完善工程。

1)、将pod包含的文件加入工程,建议将.h和.m文件放入Classes文件夹里面。

2)、在demo工程里面写一些应用示例(非必要,根据pod内容而定)。

7、 编辑.podspec文件

image

8、给工程打上tag,并上传到远程仓库

$ git tag -a 1.0.0 -m "1.0.0版本”

ps: 该标签需和.podspec文件中的s.version保持一致,同时建议标签只写1.0.0,不要写v1.0.0,因为.podspec文件中的s.version不能写“v1.0.0”,会验证不通过—__—||。

ps:显示标签

$ git tag

ps:显示标签具体信息

$ git show 1.0.0

将项目提交到远程仓库

$ git add .

$ git commit -m “初始化”

$ git push origin master

将tag推送到服务器(通常的git push不会将tag对象提交到git服务器,因此我们需要进行显式的操作)

$ git push origin 1.0.0

9、验证.podspec文件

ps:此步骤会验证.podspec文件中的s.version是否存在远程仓库的tags中,因此需要先执行8步骤

$ pod lib lint

1)、如果出现错误

- ERROR | file patterns: The source_files pattern did not match any file.

执行以下操作

cd /Users/apple/Library/Caches/CocoaPods/Pods/External/ZQExtension/d724c74446623cab90acbea4e0646f74-5d334

然后根据.podspec文件中的s.source_files和工程中的Classes路径创建相应的文件夹和文件

2)、如果出现错误

Search for existing GithHub issues similar to yours:*******

是因为版本冲突,比如我之前是pod 1.2.1版本,但是后来降到了1.0.1版本,此时需要移除repos,重新安装

$ sudo rm -fr ~/.cocoapods/repos/master

$ pod setup

3)、如果出现错误

- ERROR | [iOS] unknown: Encountered an unknown error (/usr/bin/xcrun simctl list -j devices

是因为找不到xcode路径,关联下就可以

$ sudo xcode-select -switch Xcode路径/Contents/Developer

10、将.podspec文件提交到gitHub上

$ pod trunk push ZQExtension.podspec

ps:得保证在9操作中,不能有error,可以有warnning,如果有warnning,就执行

$ pod trunk push ZQExtension.podspec --allow-warnings (注意:allow前面有两个--)

这个操作会默认检验一遍.podspec文件,基本上只要9操作无error,则会通过,但是也可能会遇到一种特殊情况,9操作可以通过,但10操作却不通过,如图所示

image

这种情况是因为.podspec文件缺少填写基本的系统依赖库,按下图添加

image

注:只要重新修改过工程中任何文件,都得先push到远程仓库

$ git add .

$ git commit -m “初始化”

$ git push origin master

可以将本次修改重新定个版本1.0.1然后重新打tag1.0.1push到远程仓库。但是不建议这么做,毕竟是小修改,无需版本迭代。

因此,如果想将这次修改也应用到1.0.0这个tag上,应该怎么做?

一开始,我以为像push到远程某个分支一样,直接执行以下操作

$ git add .

$ git commit -m “修改podspec文件”

$ git push origin 1.0.0

虽然也能push成功,但是在github远程仓库查看了下,其实并没有更新。因此只能采用最笨的方法,就是先删除本地和远程的tag,然后重新建立新的tag,push最新的工程到新的tag下,具体操作如下:

$ git tag -d 1.0.0

$ git push origin :1.0.0

$ git tag -a 1.0.0 -m "1.0.0版本”

$ git push origin 1.0.0

然后重新执行

$ pod trunk push ZQExtension.podspec

如果出现以下信息,则提交成功

image

11、更新库并进行搜索

$ pod repo update

$ pod search ZQExtension

如果出现[!] Unable to find a pod with name, author, summary, or description matching ZQExtension

执行下面操作

rm ~/Library/Caches/CocoaPods/search_index.json

然后再次执行

$ pod search ZQExtension

如果出现下面信息,则表示已经成功将该pod提交到cocoapod上

image

12、发布成功后,如果后期修改了podspec内容,podspec里面的s.version已经仓库的tag也需要相应迭代,不然执行$ pod trunk push ZQExtension.podspec会报错,意思就是不能两次都提交同一个版本的podspec

[!] Unable to accept duplicate entry for:

以下是博主做的ZQExtension的文件目录,主要是为一些常见的类添加一些常用的方法,后续会陆续更新。

image

推荐阅读更多精彩内容