Linux搭建 tensorflow-gpu环境,快速安装cuda、cudnn...

96
流川枫AI
2018.10.19 16:46* 字数 200

0.前言

好不容易找到个有GPU的机器,喜滋滋...赶快搭建一个GPU环境,跑一下Bert...

nvidia-smi
活力满满的GPU

但是...

不得不吐槽一下TensorFlow与CUDA、cuDNN的版本搭配问题...好不容易这俩货搭配好了,结果Bert使用的TensorFlow函数与本机安装的TensorFlow版本又不匹配...奔溃!


各种版本不匹配...
tensorflow与cuda、cuDNN的版本匹配表

但在群友的帮助下,发现了以下这个方式,确实好用,快速搭建!!!

1.开始

首先,学会检查本机的TensorFlow、cuda、cuDNN的版本:

1.检查CUDA版本:
使用:
nvcc -V
或:
cat /usr/local/cuda/version.txt

2.检查cuDNN版本:
cat /usr/local/cuda/include/cudnn.h | grep CUDNN_MAJOR -A 2

3.检查TensorFlow版本:
直接使用pip list查看
cuDNN版本

以下操作的前提是Linux已经安装了PIP、Anconda,即可使用以下的方式安装指定版本的TensorFlow、CUDA、cuDNN:

# 创建虚拟环境:tmp_python
conda create -n tmp_python python=2.7

# 显示自己创建的虚拟环境
conda env list
# 进入创建虚拟环境
source activate tmp_python

#安装指定 版本的TensorFlow
pip install tensorflow-gpu==1.9.0

# 安装的包
conda install cudatoolkit=9.0 -c https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/linux-64/
conda install cudnn=7.1.2 -c https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/main/linux-64/


接下来看看有没有神奇的事情发生吧....

读书笔记