在node中如何使用 ES6

ES6+ 太棒了,但是很多高级功能node是不支持的,就需要使用babel转换成ES5,

1.安装babel依赖

npm install babel-core --save-dev

2.安装babel-register

npm install babel-register --save-dev

3.babel转换配置,项目根目录添加.babelrc 文件

{
 "presets" : ['es2015']
}

这时候又需要安装es6转换模块,注意,babel不是帮我们直接转换代码的,它需要一个转换模块

npm install babel-preset-es2015 --save-dev

4.项目根目录添加入口文件 index.js

require('babel-register');
require('./app.js')

这时候就可以正常工作了,至此 ES6所有的语法都可以使用了.

推荐阅读更多精彩内容