Vue 在ie下的兼容

说到底还是es6闹得,ie浏览器不支持es6

实际碰到的问题分两步才解决

1. 直接打开是空白页:让ie支持vue

解决方式:安装 "babel-polyfill" 即可。

命令:cnpm install --save-dev babel-polyfill    //我用的是淘宝镜像,所以是cnpm,如果你没有安装使用npm 即可。

在入口main.js文件引入:import 'babel-polyfill'

最后一步,在build文件夹下找到webpack.base.conf.js.

将第10行的内容替换一下即可。

原贴:https://blog.csdn.net/landl_ww/article/details/79149461


2. 改了之后edge是没问题了,但是用360开,还是各种报错,主要是说call错误,其实还是有es6的问题,但是是node_modules里的文件了,于是在这改,让这些文件也转成es5。


。。。。。。。。

于是,能愉快和ie玩耍了。。。。

推荐阅读更多精彩内容