升级Android Studio2020.3之后问题处理

报错如下:

[!] Android Studio (version 2020.3)
    ✗ Flutter plugin not installed; this adds Flutter specific functionality.
    ✗ Dart plugin not installed; this adds Dart specific functionality.
    ✗ Unable to find bundled Java version.
  • 一、FlutterDart插件找不到问题解决办法

执行以下命令,创建替身文件夹:
$ ln -s ~/Library/Application\ Support/Google/AndroidStudio2020.3/plugins ~/Library/Application\ Support/AndroidStudio2020.3

会生成一个~/Library/Application\ Support/AndroidStudio2020.3替身文件夹。
如下:

image.png

  • 二、Unable to find bundled Java version问题解决办法

  1. 如果/Applications/Android Studio.app/Contents/jre下没有jdk文件夹,创建一个文件夹。
  2. /Applications/Android Studio.app/Contents/jre/Contents整个拷贝到jdk下一份。
  3. 重新执行flutter doctor

如下:


image.png
  • 三、搜索中文全是方格

解决办法,勾选以下选项即可:


image.png

推荐阅读更多精彩内容