windows下安装composer

Composer 是 PHP 的一个依赖管理工具。它允许你申明项目所依赖的代码库,它会在你的项目中为你安装他们。

系统要求
运行 Composer 需要 PHP 5.3.2+ 以上版本。

安装文件
https://getcomposer.org/Composer-Setup.exe
使用上面面的安装文件直接安装即可(全局安装),本文只是记录了windows下的安装过程,linux和mac请参考:https://docs.phpcomposer.com/00-intro.html

composer.json
要开始在你的项目中使用 Composer,你只需要一个 composer.json 文件。该文件包含了项目的依赖和其它的一些元数据。
本文以rabbitMQ扩展包为例,

{
    "name": "rabbitMQ project",
    "description": "rabbitMQ project.",
    "require": {
        "php-amqplib/php-amqplib": ">=2.6.1"
    },
    "repositories": {
        "packagist": {
            "type": "composer",
            "url": "https://packagist.phpcomposer.com"
        }
    }
}

repositories节点是使用了国内的镜像,原因你懂的。

安装依赖
composer install

composer install

自动加载

对于库的自动加载信息,Composer 生成了一个 vendor/autoload.php 文件。你可以简单的引入这个文件,你会得到一个免费的自动加载支持。

require 'vendor/autoload.php';

推荐阅读更多精彩内容