React-native 版本更新

96
简翦儋箪
2016.11.15 14:56* 字数 375

React-native 版本升级

1.首先到项目里面的package.json ,然后在dependencies模块下找到react-native,把里面的版本写成最新的版本。

2. 先 npm install ,如果出现权限错误问题,先在前面加上sudo npm Install

3.npm install 过程中,如果出现 Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue  ,说明版minimatch版本太低  直接 npm install minimatch@"3.0.2"更新包就好了

4.npm install 更新完成后,如果例如require react@某.某.某版本, but none was installed,说明react版本太低 要更新一下  npm install react@~x.x.x版本 —save

5. react-native upgrade 检查最新的项目模板:

* 如果是新添加的文件,则直接创建。

* 如果文件和当前版本的文件相同,则跳过。

* 如果文件和当前版本的文件不同,则会提示你一些选项:查看两者的不同,选择保留你的版本或是用新的模板覆盖。你可以按下h键来查看所有可以使用的命令。

最后,运行你的项目就ok了,这个时候可能会出现三方插件找不到的情况,重新装一下就ok了,如果还有其他的报错,一般都是你的项目代码有问题,或者三方插件配置被重置了,具体问题具体解决就可以了。

日记本