Cocoapods常用命令及介绍

96
reloadRen
2016.06.13 22:19* 字数 541

Cocoapods

CocoaPods 是 iOS 最常用最有名的类库管理工具
作为 iOS 程序员,掌握 CocoaPods 的使用是必不可少的基本技能

删除源(这个系统自带的不好用)

$ sudo gem sources -r https://rubygems.org/

添加源(使用淘宝的镜像,记住要用https)

$ sudo gem sources -a https://ruby.taobao.org/

现在淘宝的镜像还可以使用,但是不维护了。之前维护的人员现在开始维护https://gems.ruby-china.org/这个镜像,所以建议使用这个

查看是否使用的是淘宝镜像

$ gem sources -l

安装

$ sudo gem install cocoapods

安装成功之后,查看是否是最后版本(目前最新版本是1.0.1)

$ pod --version

接下来进行安装,执行:

$ pod setup
最后一步,可能会停留在 Setting up CocoaPods master repo 这个状态一段时间,是因为要进行下载安装,而且目录比较大,需要耐心等待一下

如果一段时间后想要更新本地仓库

  • 可以先使用pod repo update方法试试。

    • 可能会报错
    [!] Failed to connect to GitHub to update the CocoaPods/Specs specs repo - Please check if you are offline, or that GitHub is down
    
  • 第二种方法就比较直接:

cd ~/.cocoapods
cd repos
cd master
ls -a
git pull
//ls -a是显示该文件夹下的隐藏文件,会发现有一个.git文件说明该文件夹是一个git厂库,说以可以使用git的方法更新该文件夹的内容 
//git pull等待执行完毕即可

安装过程中常见的问题

[!] Pod::Executable clone 'https://github.com/CocoaPods/Specs.git' master

xcrun: error: active developer path ("/Users/xiakejie/工具/Xcode 2.app/Contents/Developer") does not exist, use xcode-select to change

解决上面这个问题, 使用下面这个命令:

 sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer

使用pod search 搜索出来的第三框架版本过低解决办法

有时候在终端输入pod search AFN的时候,发现搜索出来的AFN版本比Github的版本低

这个时候在终端中输入 pod repo update 即可!,这个命令是去更新cocoapods的主库
使用

搜索,先搜索一下,你需要用到的框架

$ pod search AFNetworking

生成方式 只创建Podfile(记住要到工程目录下,没有后缀)

$ touch Podfile

安装

$ pod install

升级 (推荐用update,其中update就包含了install)

$ pod update

如果update 或 install 卡住了,可以用下面两个命令替代(前提是你已经把第三方库下载下来了)

$ pod install --verbose --no-repo-update
$ pod update --verbose --no-repo-update
Podfile 参考文件(cocoapods 1.0.1版本, 注意:0.3.9版本文件不一样)
source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '7.0'

target '07-cocoapods演示' do
pod 'AFNetworking', '~> 3.0.4'
end
iOS基础
Gupao