pod 'ReactiveCocoa', ‘2.5’

platform  :ios,  ‘8.0’

#use_frameworks!    一定要加的,感叹号也不能少

use_frameworks!

target   ‘XLsn0wCocoa’  do

#ReactiveCocoa从3.0版本,使用Swift重写,最低支持iOS8.0,选择兼容性版本更低的2.5只有objc代码兼容7.0

pod  'ReactiveCocoa',  ‘2.5’

end

#-> ReactiveCocoa (5.0.0-rc.1)

#Streams of values over time

#pod 'ReactiveCocoa', '~> 5.0.0-rc.1'

#- Homepage:https://github.com/ReactiveCocoa/ReactiveCocoa

#- Source:https://github.com/ReactiveCocoa/ReactiveCocoa.git

#- Versions: 5.0.0-rc.1, 5.0.0-alpha.6, 5.0.0-alpha.5, 5.0.0-alpha.3, 5.0.0-alpha.2, 4.2.2, 4.2.1, 4.1.0,

#4.0.4-alpha-4, 4.0.4-alpha-1, 4.0.3-alpha-3, 4.0.3-alpha-1, 4.0.2-alpha-3, 4.0.2-alpha-1, 4.0.1, 4.0.1-alpha-3,

#4.0.1-alpha-1, 4.0.0, 4.0.0-alpha-3, 4.0.0-alpha-2, 4.0.0-alpha-1, 4.0.0-RC.2, 4.0.0-RC.1, 3.0.0, 3.0.0-swift2,

#3.0-beta.9, 3.0-beta.6, 3.0-alpha.3, 3.0.0-alpha.1, 3.0-RC.1, 2.5, 2.4.7, 2.4.6, 2.4.5, 2.4.4, 2.4.2, 2.3.1, 2.3,

#2.2.4, 2.2.3, 2.2.2, 2.2, 2.1.8, 2.1.7, 2.1.6, 2.1.5, 2.1.4, 2.1.3, 2.1.2, 2.1.1, 2.1, 2.0, 1.9.7, 1.9.6, 1.9.5,

#1.9.4, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.0, 1.5.0, 1.4.0, 1.3.1, 1.0.0, 0.17.1, 0.16.1, 0.13.1, 0.12.0, 0.10.0,

#0.9.0, 0.8.0, 0.6.0, 0.5.0, 0.0.1 [master repo]

推荐阅读更多精彩内容