关于macOS High Sierra 10.13 中pod失效的解决

字数 194阅读 73

最近升级了macOS High Sierra 10.13.1,但是cocoapods却出问题了。

1.在终端中输"pod install",报错-bash: /usr/local/bin/pod: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby: bad interpreter: No such file or directory

2.

百度的解决方案

根据网上百度到的解决方案,在终端输入"sudo gem update --system",报错

ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)SSL_connect returned=1errno=0state=SSLv3 read server certificate B: certificate verify failed (https://ruby.taobao.org/specs.4.8.gz)

此处报错的原因是taobao 的 gem 源的 https 证书问题,淘宝的 gem 源已经不再维护了。

解决方法:gem sources --add https://gems.ruby-china.org/ --remove https://ruby.taobao.org/

然后再按照上面图片上的一步一步来就可以了。

推荐阅读更多精彩内容