[Taro] Taro CLI 与本地安装运行时框架 @tarojs/taro-weapp 版本不一致

因为原先开发小程序的时候Taro还是1.3.10,现在换了电脑安装了Taro 2.0,结果编译运行项目的时候就报错了。


image
image

本地Taro版本与项目Taro版本不一致。

所以需要更新项目的Taro版本。

# 首先更新 Taro CLI 工具,全部升级至最新版本

# taro
$ taro update self 
# npm
npm i -g @tarojs/cli
# yarn
yarn global add @tarojs/cli

# 更新项目中 Taro 相关的依赖

$ taro update project 

本地更新至了Taro 2.0.3,但是taro update project更新后,package.json内@tarojs/taro-weapp为1.3.37,导致本地与项目Taro版本还是不一致,所以在使用taro update project时添加相应的版本号。

但是再次编译还是报不一致的错误,需要删除node_modules之后重新安装依赖。

推荐阅读更多精彩内容