Mac M1 安装Cocoapod失败,提示You don't have write permissions

参照该问题: https://stackoverflow.com/questions/66128681/ruby-build-failed-macos-11-2-using-ruby-build-20210119-mac-big-sur

把brew , rbenv 都安装在x86架构下运行

主要方法就是在安装命令前面加上 arch -x86_64

安装brew: arch -x86_64 /usr/bin/ruby -e "$(curl -fsSL https://cdn.jsdelivr.net/gh/ineo6/homebrew-install/install)"

安装rbenv: arch -x86_64 brew install rbenv

安装ruby: arch -x86_64 rbenv install 2.7.2

查看已安装的ruby: rbenv versions

查看当前使用的ruby版本: rbenv version

切换ruby版本:
arch -x86_64 rbenv global 2.7.2 # 设置全局默认使用的版本
arch -x86_64 rbenv shell 2.7.2 # 切换ruby版本

如果提示要初始化,那就运行一下: arch -x86_64 rbenv init

查看版本:ruby -v 是2.7.2则运行下面命令

安装cocoapods: arch -x86_64 sudo gem install -n /usr/local/bin cocoapods

推荐阅读更多精彩内容