SHA384 is not supported by your openssl extension, could not verify the phar file integrity

ubuntu composer 安装包的时候报错 总之 经常报错
比如 这个
Failed to decode response: zlib_decode(): data error
原因
composer 版本过低
ok 升级吧
composer self-update
又报错
对 就是那个SHA384 不支持的错 php 7.2.18 openssl扩展开启
openssl_get_md_methods() 打印显示 sha384 是支持的

这 就陷入知识的盲区了
composer官方 这是什么鬼?
emmmmmmmmmm 百度 google 不管用
好吧
我祭大刀
·有些问题 还是办蛮来得快·
卸载composer
where is composer
/usr/local/bin/composer
sudo rm -f /usr/local/bin/composer
然后 https://getcomposer.org/download/
php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('sha384', 'composer-setup.php') === '48e3236262b34d30969dca3c37281b3b4bbe3221bda826ac6a9a62d6444cdb0dcd0615698a5cbe587c3f0fe57a54d8f5') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"
嗯 这时候是OK的 wtf????
已经下载好了composer.phar 了
sudo php composer.phar -v 显示版本1.8.5
ok 这时候需要上点简单的了
sudo mkdir -p /usr/local/composer/
sudo mv compsoer.phar /usr/local/composer
sudo ln -s /usr/local/composer/composer.phar /usr/local/bin/compoer
这时候执行composer 还得php compoer
OK 我们继续
https://blog.csdn.net/zhaozhichenghpu/article/details/80934157
添加一行 alias
alias composer='php /usr/local/bin/composer'
保存
OK
这时候 compsoer 就能直接使用了

思路
卸载 重装 最后让自己用的时候方便点