PAT Advanced 1025. PAT Ranking (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

Programming Ability Test (PAT) is organized by the College of Computer Science
and Technology of Zhejiang University. Each test is supposed to run
simultaneously in several places, and the ranklists will be merged immediately
after the test. Now it is your job to write a program to correctly merge all
the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains
a positive number N ( \le 100 ), the number of test locations. Then N
ranklists follow, each starts with a line containing a positive integer K (
\le 300 ), the number of testees, and then K lines containing the
registration number (a 13-digit number) and the total score of each testee.
All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then
print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N . The output must be sorted in
nondecreasing order of the final ranks. The testees with the same score must
have the same rank, and the output must be sorted in nondecreasing order of
their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

思路

一道有关于排序的题目。题目要求得到每个考生分排名和总排名,因此关键点就在于如何
排序。

思路:由于读取是以考点为组,因此可以在每读完一个考点,即对此考点内的考生进
行排序,得到分排名。最后再对整个列表进行排序,得到总排名。

实现

使用一个数组存储。排序时,使用qsort传入不同位置和长度参数即可。

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

/* registration number, location nubmer, total score, final rank, local rank */
typedef struct {
    char reg[14];
    int loc, score, rank, lrank;
} Testee, *pTestee;

int cmp(const void *a, const void *b)
{
    pTestee p1 = *(pTestee*)a, p2 = *(pTestee*)b;
    if(p1->score != p2->score)
        return p2->score - p1->score;
    else
        return strcmp(p1->reg, p2->reg);
}

int main()
{
    int N, K;
    Testee buffers[100 * 300] = {0}, *q = buffers;
    pTestee testees[100 * 300] = {0}, *p = testees;

    scanf("%d", &N);
    for(int n = 0; n < N; n++)
    {
        /* read one test location */
        scanf("%d", &K);
        for(int k = 0; k < K; k++, p++)
        {
            *p = q++;  /* use a new cell */
            (*p)->loc = n + 1;
            scanf("%s %d", (*p)->reg, &(*p)->score);
        }

        /* sort the kth location sublist */
        qsort(p - K, K, sizeof(pTestee), cmp);

        /* get the local rank, i is the offset (we need left K cells of p) */
        int lrank = 1;
        pTestee *lp;
        (*(p - K))->lrank = lrank;  /* boundary special case */
        for(int i = 1; i < K; i++)
        {
            lp = p - K + i;
            if((*lp)->score != (*(lp - 1))->score)
                lrank = i + 1;
            (*lp)->lrank = lrank;
        }
    }

    /* sort the whole list */
    qsort(testees, p - testees, sizeof(pTestee), cmp);
    /* get the final rank */
    int rank = 1;
    pTestee *fp;
    (*testees)->rank = rank;
    for(int i = 1; testees + i < p; i++)
    {
        fp = testees + i;
        if((*fp)->score != (*(fp - 1))->score)
            rank = i + 1;
        (*fp)->rank = rank;
    }

    /* output */
    printf("%ld\n", p - testees);
    for(pTestee* i = testees; i < p; i++)
        printf("%s %d %d %d\n", (*i)->reg, (*i)->rank, (*i)->loc, (*i)->lrank);

    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 158,560评论 4 361
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,104评论 1 291
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 108,297评论 0 243
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 43,869评论 0 204
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,275评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,563评论 1 216
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,833评论 2 312
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,543评论 0 197
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,245评论 1 241
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,512评论 2 244
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,011评论 1 258
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,359评论 2 253
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,006评论 3 235
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,062评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,825评论 0 194
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,590评论 2 273
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,501评论 2 268

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,102评论 0 10
  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 8,571评论 0 23
  • The Inner Game of Tennis W Timothy Gallwey Jonathan Cape ...
    网事_79a3阅读 11,003评论 2 18
  • 我感激上天让我遇见你 我感激你是个重情义的人 感激那么多日子后你仍没忘我 我却似乎忘了些什么 我期待...
    柏芷阅读 202评论 0 0
  • 中国的父母从来不和孩子谈性,认为谈性会教导坏孩子,孩子可能去做一些不好的事情,而这种事情历来在中国是最为人所不齿的...
    陌暮阅读 325评论 1 1