Api使用方式

LuaIde 0.4.5 版本添加了 对各lua解决方案 Api 的支持

第一步:生成api文件

1.cocos生成

2.ulua生成

3.slua生成

4.xlua生成

第二步: 配置

LuaIde 默认导出了4份api 分别为:

          1.quick2.2.6

           2.Quick-Cocos2dx-Community 3.6

           3.ulua LuaFramework_NGUI

            4.slua 1.3.3 

            5.xlua 2.1.9 

注意:如果不能满足需求或需要使用开发者自己添加的api 请自行导出并将导出的lua文件放入工作目录的 luaIde 目录下并注意大小写 (luaIde)   unity版本默认导出路径在assets/luaide 下  工作目录即为assest 那么可以不做任何操作


luaide api 放入位置

配置luaide api 

选择设置 在搜索设置中输入 luaide.aipType 进行设置 建议 将该设置放入 工作区设置 这样可以针对不同的项目设置不同的api

使用:

luaide 内置了代码推断功能 在能够解析出类型是不需要使用标签进行标注 如:


推断

不能确定类型 那么需要开发者自行添加标签如:

具体的标签使用请查看  luaIde 标签使用

推荐阅读更多精彩内容