暂停Xcode13的更新

第一时间更新了Xcode13,模拟器运行iPhone 13 Pro max,很快,没毛病。心里窃喜,又是一次无感的升级。我还是太天真啊!


天真

一切都很美好
欢欢喜喜的做着开心的事
总是在最后来一个措手不及

报错

升级下第三方库,修复修复警告,开发完成新功能。一切都是那么的perfect。然后打包提测。发现错误从天而降。

View

有点懵的。Xcode12时,一切都是好好的。运行模拟器也是正常的。看到报错的是Parchment第三方库。

原因

赶紧到Parchment中查看下,是不是有其他人也碰到了问题。发现“Package.swift must be updated if it's installed via Swift Package Manager”,和我碰到的比较类似了。也提供了临时的解决方案,但不适合我。
最后看到

惊讶

我找了3天的问题,终于有一个明确的答案了。这个锅Xcode来背。
Xcode13的更新说明中,竟然有一条叫”Known Issues“,明知有问题还发布出来坑人,太不厚道了。

解决

1. 下载Xcode12版本

还是用老版本吧,这个是最稳妥的。

2. 项目的最低版本修改为iOS12

看公司项目的使用用户情况而定。好多大公司的最低支持版本为iOS9,还是不要提这个解决方法给Leader了。

等等等

等Xcode13.1版本吧。

推荐阅读更多精彩内容