xcode-select: error: tool 'xcodebuild' requires Xcode

有一天,我下了AudioKit准备体验他的一些比较酷的东西。结果出现了一个错误。

In Terminal 

$ cd framework_dirs 

$ ./build_frameworks.sh

Building frameworks for platforms: iOS macOS tvOS

xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance


what's going on?

我猜可能是我刚刚重装了笔记本,xcodebuild找不到Xcode,所以我们要重定向一下Xcode的文档的位置。

$ sudo xcode-select --switch /Applications/Xcode.app/Contents/Developer/

输入密码后就搞定了。

推荐阅读更多精彩内容