×
广告

记一次导入lottie动画库出现support.v4库冲突的解决方法

96
汪和呆喵
2018.03.13 15:04* 字数 129

今天在项目里导入lottie包,遇到与support-v4库冲突报错的问题

最终找到解决方法如下:

1. 首先替换项目中已存在的support.v4库版本

compile 'com.android.support:support-v4:24.0.0-alpha1'

compile 'com.android.support:support-v4:25.3.0'

注意support-v4库的26以上版本移除了android.support.v4.animation包 

2.使用gradle的exclude排除lottie库中包含的v4包

compile ('com.airbnb.android:lottie:2.5.1') {

    exclude group:'com.android.support'

}

冲突解决.

技术文章
Web note ad 1